McElroy Discussion Forums
http://forums.mcelroy.com/fusion/

TRACSTAR 500 HEATER ISSUES
http://forums.mcelroy.com/fusion/viewtopic.php?f=2&t=2007
Page 1 of 1

Author:  GeneralQuestion [ July 7th, 2017, 1:57 pm ]
Post subject:  TRACSTAR 500 HEATER ISSUES

I am fairly new to working on these so maybe I am missing something obvious here so any help is appreciated.
I have a T500 Gen 3 that is doing some crazy stuff, I will post all info I have so far and see if that gets me anywhere.

-in low idle my heater will come on when switch is in the on position and works as if you had the machine in high idle
-in fuel saver mode(idle switch in the down position) I can turn the heater on and everything works fine until I turn the heater off and it will pop the circuit breaker
-in high idle mode(idle switch in the up position) I can turn the heater on and everything works fine until I turn the heater off and it will pop the circuit breaker
-this machine was equipped with the new heater Mod kit with the solid state relay by an unknown mechanic before my time.
-I have pulled directions up on this kit to ensure everything is correctly installed and from what I can tell we are good there.
-generator is reading the correct voltage as well.
-I have pulled the cap off of the top of the heater to ensure there was not any direct shorts that were clearly visible
-I have visually checked all the plugs throughout the machine, inside the heater box, and have also changed the circuit breaker to a KNOW GOOD ONE.

Like I said I am new to these specific machines but have a good knowledge in mechanics and electrical, I am just kind of at a stand still at the moment with this machine. Maybe I am missing something, any help is very much appreciated and thank you in advance.

Author:  Jesse Smith [ July 28th, 2017, 3:56 pm ]
Post subject:  Re: TRACSTAR 500 HEATER ISSUES

Sorry in advance for the delayed response to your post. This sounds like a sounds like an issue that will require some in depth trouble shooting to solve. Someone here in our tech services department will be happy to help you out if you haven't figured it out already.
please give tech support a call @ 918-831-9224

Page 1 of 1 All times are UTC - 6 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/